blob: 40199343eea8e77de1532061d9d2585e4249951d [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "The glog library implements application-level logging. This \
2library provides logging APIs based on C++-style streams and various helper \
3macros."
4HOMEPAGE = "https://github.com/google/glog"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://COPYING;md5=dc9db360e0bbd4e46672f3fd91dd6c4b"
8
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009SRC_URI = " \
Brad Bishope42b3e32020-01-15 22:08:42 -050010 git://github.com/google/glog.git;nobranch=1 \
Andrew Geissler32b11992021-03-31 13:37:05 -050011 file://libexecinfo.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012"
13
Andrew Geissler69721092021-07-23 12:57:00 -040014SRCREV = "8f9ccfe770add9e4c64e9b25c102658e3c763b73"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
16S = "${WORKDIR}/git"
17
18inherit cmake
19
Andrew Geissler82c905d2020-04-13 13:39:40 -050020PACKAGECONFIG ?= "shared unwind"
Patrick Williams213cb262021-08-07 19:21:33 -050021PACKAGECONFIG:remove:riscv64 = "unwind"
22PACKAGECONFIG:remove:riscv32 = "unwind"
23PACKAGECONFIG:append:libc-musl:riscv64 = " execinfo"
24PACKAGECONFIG:append:libc-musl:riscv32 = " execinfo"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025
Andrew Geissler82c905d2020-04-13 13:39:40 -050026PACKAGECONFIG[unwind] = "-DWITH_UNWIND=ON,-DWITH_UNWIND=OFF,libunwind,libunwind"
Andrew Geissler32b11992021-03-31 13:37:05 -050027PACKAGECONFIG[execinfo] = ",,libexecinfo"
Andrew Geissler82c905d2020-04-13 13:39:40 -050028PACKAGECONFIG[shared] = "-DBUILD_SHARED_LIBS=ON,-DBUILD_SHARED_LIBS=OFF,,"
Andrew Geisslera2681d92020-10-16 10:17:07 -050029
Patrick Williams213cb262021-08-07 19:21:33 -050030do_configure:append() {
Andrew Geisslera2681d92020-10-16 10:17:07 -050031 # remove WORKDIR info to improve reproducibility
32 if [ -f "${B}/config.h" ] ; then
33 sed -i 's/'$(echo ${WORKDIR} | sed 's_/_\\/_g')'/../g' ${B}/config.h
34 fi
35}