blob: 1633ecfecff17fc7684e477f4016861f1cae1476 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001DESCRIPTION = "Trusted Services ts-remote-test deployment for arm-linux."
2
3TS_ENV = "arm-linux"
4
5require trusted-services.inc
6
7DEPENDS += "libts"
8RDEPENDS:${PN} += "libts"
9
10OECMAKE_SOURCEPATH = "${S}/deployments/ts-remote-test/${TS_ENV}"
11
12FILES:${PN} = "${bindir}/ts-remote-test"
Andrew Geissler220dafd2023-10-04 10:18:08 -050013
14do_install:append () {
15 install -d ${D}${bindir}
16 mv ${D}${TS_INSTALL}/bin/ts-remote-test ${D}${bindir}
17
18 rm -r --one-file-system ${D}${TS_INSTALL}
19}