blob: 54bd52c61aac2adec98374084e2f809b040e650b [file] [log] [blame]
Andrew Geissler220dafd2023-10-04 10:18:08 -05001Upstream-Status: Pending
2
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05003Description: Bring Clang's _Nonnull keyword to GCC
4Author: Kai-Chung Yan
5Forwarded: not-needed
6--- a/system/core/adb/sysdeps.h
7+++ b/system/core/adb/sysdeps.h
8@@ -40,11 +40,12 @@
9 #include "sysdeps/network.h"
10 #include "sysdeps/stat.h"
11
12+#define _Nonnull
13+#define _Nullable
14+
15 #ifdef _WIN32
16
17 // Clang-only nullability specifiers
18-#define _Nonnull
19-#define _Nullable
20
21 #include <ctype.h>
22 #include <direct.h>