blob: 441031f53621e7dfb407ef835249b3963d8c5301 [file] [log] [blame]
Andrew Geissler220dafd2023-10-04 10:18:08 -05001Upstream-Status: Pending
2
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05003Description: remove clang-ism
4Forwarded: not-needed
5
6--- a/system/core/base/include/android-base/logging.h
7+++ b/system/core/base/include/android-base/logging.h
8@@ -451,10 +451,7 @@
9 // -Wno-user-defined-warnings to CPPFLAGS.
10 #pragma clang diagnostic push
11 #pragma clang diagnostic ignored "-Wgcc-compat"
12-#define OSTREAM_STRING_POINTER_USAGE_WARNING \
13- __attribute__((diagnose_if(true, "Unexpected logging of string pointer", "warning")))
14-inline OSTREAM_STRING_POINTER_USAGE_WARNING
15-std::ostream& operator<<(std::ostream& stream, const std::string* string_pointer) {
16+inline std::ostream& operator<<(std::ostream& stream, const std::string* string_pointer) {
17 return stream << static_cast<const void*>(string_pointer);
18 }
19 #pragma clang diagnostic pop