blob: 5f24d0b4a061392b8f9b445ffd593afc6519150c [file] [log] [blame]
Andrew Geissler220dafd2023-10-04 10:18:08 -05001Upstream-Status: Pending
2
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05003Description: get libcutils building
4Forwarded: not-needed
5--- a/system/core/libcutils/include/cutils/threads.h
6+++ b/system/core/libcutils/include/cutils/threads.h
7@@ -33,7 +33,7 @@
8 // Deprecated: use android::base::GetThreadId instead, which doesn't truncate on Mac/Windows.
9 //
10
11-extern pid_t gettid();
12+extern pid_t gettid(void) __THROW;
13
14 //
15 // Deprecated: use `_Thread_local` in C or `thread_local` in C++.
16--- a/system/core/libcutils/threads.cpp
17+++ b/system/core/libcutils/threads.cpp
18@@ -33,7 +33,7 @@
19
20 // No definition needed for Android because we'll just pick up bionic's copy.
21 #ifndef __ANDROID__
22-pid_t gettid() {
23+pid_t gettid(void) __THROW {
24 #if defined(__APPLE__)
25 uint64_t tid;
26 pthread_threadid_np(NULL, &tid);