blob: 670bebd37ba857a52080610710b35e2c6aa8001e [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "libblockdev is a C library supporting GObject introspection for manipulation of \
2block devices. It has a plugin-based architecture where each technology (like \
3LVM, Btrfs, MD RAID, Swap,...) is implemented in a separate plugin, possibly \
4with multiple implementations (e.g. using LVM CLI or the new LVM DBus API)."
5HOMEPAGE = "http://rhinstaller.github.io/libblockdev/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00006LICENSE = "LGPL-2.0-or-later"
Brad Bishop19323692019-04-05 15:28:33 -04007SECTION = "devel/lib"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
10
Patrick Williamse760df82023-05-26 11:10:49 -050011inherit autotools gobject-introspection pkgconfig lib_package
12
Andrew Geissler220dafd2023-10-04 10:18:08 -050013DEPENDS = "autoconf-archive-native glib-2.0 kmod udev libnvme"
Brad Bishop19323692019-04-05 15:28:33 -040014
Andrew Geissler220dafd2023-10-04 10:18:08 -050015SRC_URI = "git://github.com/storaged-project/libblockdev;branch=master;protocol=https \
Andrew Geissler595f6302022-01-24 19:11:47 +000016"
Andrew Geissler220dafd2023-10-04 10:18:08 -050017SRCREV = "38378931d285b91333ff2e2a391b1fe91072f9bb"
Brad Bishop19323692019-04-05 15:28:33 -040018S = "${WORKDIR}/git"
19
Andrew Geissler220dafd2023-10-04 10:18:08 -050020FILES:${PN} += "${libdir}/python3.*/site-packages"
Brad Bishop19323692019-04-05 15:28:33 -040021
Andrew Geissler220dafd2023-10-04 10:18:08 -050022PACKAGECONFIG ??= "python3 lvm lvm-dbus dm parted fs escrow btrfs crypto mdraid mpath nvdimm tools"
Brad Bishop19323692019-04-05 15:28:33 -040023PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
Brad Bishop19323692019-04-05 15:28:33 -040024PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2"
25PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus, --without-lvm_dbus, multipath-tools, lvm2"
26PACKAGECONFIG[dm] = "--with-dm, --without-dm, multipath-tools, lvm2"
Brad Bishop19323692019-04-05 15:28:33 -040027PACKAGECONFIG[parted] = "--with-part, --without-part, parted"
28PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux"
29PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
30PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm, ndctl util-linux"
Brad Bishop19323692019-04-05 15:28:33 -040031PACKAGECONFIG[escrow] = "--with-escrow, --without-escrow, nss volume-key"
32PACKAGECONFIG[btrfs] = "--with-btrfs,--without-btrfs,libbytesize btrfs-tools"
33PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,cryptsetup nss volume-key"
34PACKAGECONFIG[mdraid] = "--with-mdraid,--without-mdraid,libbytesize"
Brad Bishop19323692019-04-05 15:28:33 -040035PACKAGECONFIG[mpath] = "--with-mpath,--without-mpath, multipath-tools, lvm2"
Patrick Williamse760df82023-05-26 11:10:49 -050036PACKAGECONFIG[tools] = "--with-tools,--without-tools,libbytesize libdevmapper"
Brad Bishop19323692019-04-05 15:28:33 -040037
38export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs"