blob: 2628b771023ad9a5aded08e3cc7b55db8abb980d [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The Geolocation Service"
2DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
3The primary goal of the Geoclue project is to make creating location-aware applications \
4as simple as possible, while the secondary goal is to ensure that no application \
5can access location information without explicit permission from user."
6LICENSE = "GPL-2.0-or-later"
7SECTION = "console/network"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=bdfdd4986a0853eb84eeba85f9d0c4d6"
10
11DEPENDS = "glib-2.0 dbus json-glib libsoup-3.0 intltool-native"
12
13inherit meson pkgconfig gtk-doc gobject-introspection vala useradd
14
Andrew Geissler220dafd2023-10-04 10:18:08 -050015SRCREV = "8a24f60969d4c235d9918796c38a6a9c42e10131"
Andrew Geissler5082cc72023-09-11 08:41:39 -040016SRC_URI = "git://gitlab.freedesktop.org/geoclue/geoclue.git;protocol=https;branch=master \
Andrew Geissler3eeda902023-05-19 10:14:02 -050017 file://0001-libgeoclue-don-t-try-to-use-g-ir-scanner-when-intros.patch \
18"
Andrew Geissler517393d2023-01-13 08:55:19 -060019
20S = "${WORKDIR}/git"
21
22# Without this line, package is declared a library and named libgeoclue*
23AUTO_LIBNAME_PKGS = ""
24
25PACKAGECONFIG ??= "3g modem-gps cdma nmea lib"
26PACKAGECONFIG[3g] = "-D3g-source=true,-D3g-source=false,modemmanager"
27PACKAGECONFIG[modem-gps] = "-Dmodem-gps-source=true,-Dmodem-gps-source=false,modemmanager"
28PACKAGECONFIG[cdma] = "-Dcdma-source=true,-Dcdma-source=false,modemmanager"
29PACKAGECONFIG[nmea] = "-Dnmea-source=true,-Dnmea-source=false,avahi,avahi-daemon"
Patrick Williamse760df82023-05-26 11:10:49 -050030PACKAGECONFIG[lib] = "-Dlibgeoclue=true,-Dlibgeoclue=false"
Andrew Geissler517393d2023-01-13 08:55:19 -060031
32GTKDOC_MESON_OPTION = "gtk-doc"
33
34EXTRA_OEMESON += " \
35 -Ddbus-sys-dir=${sysconfdir}/dbus-1/system.d \
36 -Ddemo-agent=false \
37"
38
39USERADD_PACKAGES = "${PN}"
40USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 --shell /bin/nologin polkitd"
41
42do_install:append() {
43 if ${@bb.utils.contains('PACKAGECONFIG', 'modem-gps', 'true', 'false', d)}; then
44 # Fix up permissions on polkit rules.d to work with rpm4 constraints
45 chmod 700 ${D}/${datadir}/polkit-1/rules.d
46 chown polkitd:root ${D}/${datadir}/polkit-1/rules.d
47 fi
48}
49
50FILES:${PN} += " \
51 ${datadir}/dbus-1/system-services \
52 ${datadir}/polkit-1/rules.d \
53 ${libdir} \
54 ${systemd_unitdir} \
55 ${prefix}/libexec \
56"
57
58FILES:${PN}-dev += " \
59 ${datadir}/dbus-1/interfaces \
60 ${datadir}/gir-1.0 \
61"