blob: 055b41bfa53ec1668703c00fc38faac548ee3fd3 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \
2Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
3Contributors."
4HOMEPAGE = "https://pillow.readthedocs.io"
5LICENSE = "MIT"
Patrick Williams8e7b46e2023-05-01 14:19:06 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=b22dc6b663b9175820e5e03337c7596b"
Andrew Geissler517393d2023-01-13 08:55:19 -06007
Andrew Geissler220dafd2023-10-04 10:18:08 -05008SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=10.0.x;protocol=https \
Andrew Geissler517393d2023-01-13 08:55:19 -06009 file://0001-support-cross-compiling.patch \
10 file://0001-explicitly-set-compile-options.patch \
Patrick Williams864cc432023-02-09 14:54:44 -060011 file://run-ptest \
Andrew Geissler517393d2023-01-13 08:55:19 -060012 "
13SRCREV ?= "82541b6dec8452cb612067fcebba1c5a1a2bfdc8"
14
Patrick Williams864cc432023-02-09 14:54:44 -060015inherit setuptools3 ptest
Andrew Geissler517393d2023-01-13 08:55:19 -060016
17PIP_INSTALL_PACKAGE = "Pillow"
18PIP_INSTALL_DIST_PATH = "${S}/dist"
19
20DEPENDS += " \
21 zlib \
22 jpeg \
23 tiff \
24 freetype \
25 lcms \
26 openjpeg \
27"
28
29RDEPENDS:${PN} += " \
30 ${PYTHON_PN}-misc \
31 ${PYTHON_PN}-logging \
32 ${PYTHON_PN}-numbers \
Andrew Geissler3eeda902023-05-19 10:14:02 -050033 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcb', '', d)} \
Andrew Geissler517393d2023-01-13 08:55:19 -060034"
35
Patrick Williams864cc432023-02-09 14:54:44 -060036RDEPENDS:${PN}-ptest += " \
37 bash \
38 ghostscript \
39 jpeg-tools \
40 libwebp \
41 ${PYTHON_PN}-core \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060042 ${PYTHON_PN}-distutils \
Patrick Williams864cc432023-02-09 14:54:44 -060043 ${PYTHON_PN}-image \
44 ${PYTHON_PN}-mmap \
45 ${PYTHON_PN}-pytest \
46 ${PYTHON_PN}-pytest-timeout \
47 ${PYTHON_PN}-resource \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060048 ${PYTHON_PN}-unixadmin\
Patrick Williams864cc432023-02-09 14:54:44 -060049 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'tk', '', d)} \
50"
51
Andrew Geissler517393d2023-01-13 08:55:19 -060052CVE_PRODUCT = "pillow"
53
54S = "${WORKDIR}/git"
55
56RPROVIDES:${PN} += "python3-imaging"
57
Patrick Williams864cc432023-02-09 14:54:44 -060058do_install_ptest() {
59 install -d ${D}${PTEST_PATH}/Tests
60 cp -rf ${S}/Tests ${D}${PTEST_PATH}/
61}
62
Andrew Geissler517393d2023-01-13 08:55:19 -060063BBCLASSEXTEND = "native"
64
Andrew Geissler220dafd2023-10-04 10:18:08 -050065SRCREV = "e34d346f10c0b1c814661e662a3e0c1ef084cf1c"