blob: 1eaf30746b0bce9e21e5771641fa4b082befbe65 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Device formfactor information"
Brad Bishopa34c0302019-09-23 22:34:48 -04002DESCRIPTION = "A formfactor configuration file provides information about the \
3target hardware for which the image is being built and information that the \
4build system cannot obtain from other sources such as the kernel."
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005SECTION = "base"
6LICENSE = "MIT"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
9SRC_URI = "file://config file://machconfig"
10S = "${WORKDIR}"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13INHIBIT_DEFAULT_DEPS = "1"
14
15do_install() {
16 # Install file only if it has contents
17 install -d ${D}${sysconfdir}/formfactor/
18 install -m 0644 ${S}/config ${D}${sysconfdir}/formfactor/
19 if [ -s "${S}/machconfig" ]; then
20 install -m 0644 ${S}/machconfig ${D}${sysconfdir}/formfactor/
21 fi
22}