blob: c7bd1d195e501830750c22d7d44a9d5fec8ff7f9 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "GNU file archiving program"
2DESCRIPTION = "GNU tar saves many files together into a single tape \
3or disk archive, and can restore individual files from the archive."
4HOMEPAGE = "http://www.gnu.org/software/tar/"
5SECTION = "base"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-3.0-only"
Andrew Geissler5082cc72023-09-11 08:41:39 -04007LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
Brad Bishopc342db32019-05-15 21:57:59 -04008
Andrew Geissler5082cc72023-09-11 08:41:39 -04009SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2"
Brad Bishopc342db32019-05-15 21:57:59 -040010
Andrew Geissler5082cc72023-09-11 08:41:39 -040011SRC_URI[sha256sum] = "7edb8886a3dc69420a1446e1e2d061922b642f1cf632d2cd0f9ee7e690775985"
Brad Bishopc342db32019-05-15 21:57:59 -040012
13inherit autotools gettext texinfo
14
15PACKAGECONFIG ??= ""
Patrick Williams213cb262021-08-07 19:21:33 -050016PACKAGECONFIG:append:class-target = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}"
Brad Bishopc342db32019-05-15 21:57:59 -040017
18PACKAGECONFIG[acl] = "--with-posix-acls,--without-posix-acls,acl"
Andrew Geissler5199d832021-09-24 16:47:35 -050019PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux"
Brad Bishopc342db32019-05-15 21:57:59 -040020
21EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
22
Andrew Geissler82c905d2020-04-13 13:39:40 -050023CACHED_CONFIGUREVARS += "tar_cv_path_RSH=no"
24
Brad Bishopc342db32019-05-15 21:57:59 -040025# Let aclocal use the relative path for the m4 file rather than the
26# absolute since tar has a lot of m4 files, otherwise there might
27# be an "Argument list too long" error when it is built in a long/deep
28# directory.
29acpaths = "-I ./m4"
30
31do_install () {
32 autotools_do_install
33 ln -s tar ${D}${bindir}/gtar
34}
35
Patrick Williams213cb262021-08-07 19:21:33 -050036do_install:append:class-target() {
Brad Bishopc342db32019-05-15 21:57:59 -040037 if [ "${base_bindir}" != "${bindir}" ]; then
38 install -d ${D}${base_bindir}
39 mv ${D}${bindir}/tar ${D}${base_bindir}/tar
40 mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar
41 rmdir ${D}${bindir}/
42 fi
43}
44
Andrew Geissler220dafd2023-10-04 10:18:08 -050045# add for ptest support
46SRC_URI += " \
47 file://run-ptest \
48 file://0001-tests-fix-TESTSUITE_AT.patch \
49 file://0002-tests-check-for-recently-fixed-bug.patch \
50 file://0003-Exclude-VCS-directory-with-writing-from-an-archive.patch \
51"
52
53inherit ptest
54
55do_compile_ptest() {
56 oe_runmake -C ${B}/gnu/ check
57 oe_runmake -C ${B}/lib/ check
58 oe_runmake -C ${B}/rmt/ check
59 oe_runmake -C ${B}/src/ check
60 rm -rf ${S}/tests/testsuite
61 oe_runmake -C ${B}/tests/ testsuite
62 oe_runmake -C ${B}/tests/ genfile checkseekhole ckmtime
63}
64
65do_install_ptest() {
66 install -d ${D}${PTEST_PATH}/tests/
67 install --mode=755 ${B}/tests/atconfig ${D}${PTEST_PATH}/tests/
68 sed -i "/abs_/d" ${D}${PTEST_PATH}/tests/atconfig
69 echo "abs_builddir=${PTEST_PATH}/tests/" >> ${D}${PTEST_PATH}/tests/atconfig
70 install --mode=755 ${B}/tests/atlocal ${D}${PTEST_PATH}/tests/
71 sed -i "/PATH=/d" ${D}${PTEST_PATH}/tests/atlocal
72 install --mode=755 ${B}/tests/genfile ${D}${PTEST_PATH}/tests/
73 install --mode=755 ${B}/tests/checkseekhole ${D}${PTEST_PATH}/tests/
74 install --mode=755 ${B}/tests/ckmtime ${D}${PTEST_PATH}/tests/
75 install --mode=755 ${S}/tests/testsuite ${D}${PTEST_PATH}/tests/
76 sed -i "s#@PTEST_PATH@#${PTEST_PATH}#g" ${D}${PTEST_PATH}/run-ptest
77}
78
Brad Bishopc342db32019-05-15 21:57:59 -040079PACKAGES =+ "${PN}-rmt"
80
Patrick Williams213cb262021-08-07 19:21:33 -050081FILES:${PN}-rmt = "${sbindir}/rmt*"
Brad Bishopc342db32019-05-15 21:57:59 -040082
83inherit update-alternatives
84
85ALTERNATIVE_PRIORITY = "100"
86
Patrick Williams213cb262021-08-07 19:21:33 -050087ALTERNATIVE:${PN} = "tar"
88ALTERNATIVE:${PN}-rmt = "rmt"
89ALTERNATIVE:${PN}:class-nativesdk = ""
90ALTERNATIVE:${PN}-rmt:class-nativesdk = ""
Brad Bishopc342db32019-05-15 21:57:59 -040091
92ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
93ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
94
Patrick Williams213cb262021-08-07 19:21:33 -050095PROVIDES:append:class-native = " tar-replacement-native"
Brad Bishopc342db32019-05-15 21:57:59 -040096NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
97
98BBCLASSEXTEND = "native nativesdk"
Patrick Williams0ca19cc2021-08-16 14:03:13 -050099
Andrew Geisslereff27472021-10-29 15:35:00 -0500100# Avoid false positives from CVEs in node-tar package
101# For example CVE-2021-{32803,32804,37701,37712,37713}
102CVE_PRODUCT = "gnu:tar"