blob: 6dd8af2390da0db5fc76fa9d523e96a780501227 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Tracker is a file search engine"
2LICENSE = "GPL-2.0-only & LGPL-2.1-only"
3LIC_FILES_CHKSUM = " \
4 file://COPYING.GPL;md5=ee31012bf90e7b8c108c69f197f3e3a4 \
5 file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
6"
7
8DEPENDS = " \
9 dbus-native \
10 python3-pygobject-native \
11 glib-2.0 \
12 sqlite3 \
13 libarchive \
14 dbus \
15 icu \
16 json-glib \
17 libsoup-3.0 \
18 libstemmer \
19"
20
21GNOMEBASEBUILDCLASS = "meson"
22
23inherit gnomebase gsettings gobject-introspection vala gtk-doc manpages bash-completion features_check python3native
24
Patrick Williamse760df82023-05-26 11:10:49 -050025SRC_URI += "file://0001-meson-Do-not-define-TOP_SRCDIR.patch"
Andrew Geissler3eeda902023-05-19 10:14:02 -050026SRC_URI[archive.sha256sum] = "f972d50ac7bafdccf113b1eb99dcae35404685a99e55bfef16f3ac83b4de974d"
Andrew Geissler517393d2023-01-13 08:55:19 -060027
28# gobject-introspection is mandatory and cannot be configured
29REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
30GIR_MESON_OPTION = ""
31
32# text search is not an option anymore and requires sqlite3 build with
33# PACKAGECONFIG[fts5] set (default)
34
35# set required cross property sqlite3_has_fts5
36do_write_config[vardeps] += "PACKAGECONFIG"
37do_write_config:append() {
38 echo "[properties]" > ${WORKDIR}/meson-tracker.cross
39 echo "sqlite3_has_fts5 = 'true'" >> ${WORKDIR}/meson-tracker.cross
40}
41
42EXTRA_OEMESON = " \
43 --cross-file ${WORKDIR}/meson-tracker.cross \
44 -Dman=false \
45 -Dsystemd_user_services=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} \
46 -Dsystemd_user_services_dir=${systemd_user_unitdir} \
47 -Dsoup=soup3 \
48"
49
50FILES:${PN} += " \
51 ${datadir}/dbus-1 \
52 ${datadir}/tracker3 \
53 ${libdir}/tracker-3.0 \
54 ${systemd_user_unitdir} \
55"