blob: 13f620f6336d958e1270688cc6b54204c851b504 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Network benchmark tool"
2DESCRIPTION = "\
3iperf is a tool for active measurements of the maximum achievable bandwidth \
4on IP networks. It supports tuning of various parameters related to timing, \
5protocols, and buffers. For each test it reports the bandwidth, loss, and \
6other parameters."
7
8HOMEPAGE = "http://software.es.net/iperf/"
9SECTION = "console/network"
10BUGTRACKER = "https://github.com/esnet/iperf/issues"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011
12LICENSE = "BSD-3-Clause"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050013LIC_FILES_CHKSUM = "file://LICENSE;md5=dc6301c8256ceb8f71c9e3c2ae9096b9"
Andrew Geissler9aee5002022-03-30 16:27:02 +000014
15SRC_URI = "git://github.com/esnet/iperf.git;branch=master;protocol=https \
16 file://0002-Remove-pg-from-profile_CFLAGS.patch \
17 file://0001-configure.ac-check-for-CPP-prog.patch \
18 "
19
Patrick Williams2a254922023-08-11 09:48:11 -050020SRCREV = "a0be85934144bc04712a6695b14ea6e45c379e1d"
Andrew Geissler9aee5002022-03-30 16:27:02 +000021
22S = "${WORKDIR}/git"
23
24inherit autotools
25
26PACKAGECONFIG ?= "openssl"
27
28PACKAGECONFIG[lksctp] = "ac_cv_header_netinet_sctp_h=yes,ac_cv_header_netinet_sctp_h=no,lksctp-tools"
29PACKAGECONFIG[openssl] = "--with-openssl=${RECIPE_SYSROOT}${prefix},--without-openssl,openssl"
30
31CFLAGS += "-D_GNU_SOURCE"