blob: 2e7412e8230dc79b810351cc001ab76e96f7a736 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "libblockdev is a C library supporting GObject introspection for manipulation of \
2block devices. It has a plugin-based architecture where each technology (like \
3LVM, Btrfs, MD RAID, Swap,...) is implemented in a separate plugin, possibly \
4with multiple implementations (e.g. using LVM CLI or the new LVM DBus API)."
5HOMEPAGE = "http://rhinstaller.github.io/libblockdev/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00006LICENSE = "LGPL-2.0-or-later"
Brad Bishop19323692019-04-05 15:28:33 -04007SECTION = "devel/lib"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
10
Patrick Williamse760df82023-05-26 11:10:49 -050011inherit autotools gobject-introspection pkgconfig lib_package
12
13DEPENDS = "autoconf-archive-native glib-2.0 kmod udev"
Brad Bishop19323692019-04-05 15:28:33 -040014
Andrew Geissler595f6302022-01-24 19:11:47 +000015SRC_URI = "git://github.com/storaged-project/libblockdev;branch=2.x-branch;protocol=https \
Andrew Geissler595f6302022-01-24 19:11:47 +000016"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050017SRCREV = "1412dc51c8f76bf8d9a6008228737db4a9a26d69"
Brad Bishop19323692019-04-05 15:28:33 -040018S = "${WORKDIR}/git"
19
Patrick Williams213cb262021-08-07 19:21:33 -050020FILES:${PN} += "${libdir}/python2.7/dist-packages ${libdir}/python3.*/site-packages"
Brad Bishop19323692019-04-05 15:28:33 -040021
Patrick Williamse760df82023-05-26 11:10:49 -050022PACKAGECONFIG ??= "python3 lvm dm kmod parted fs escrow btrfs crypto mdraid kbd mpath nvdimm tools"
Brad Bishop19323692019-04-05 15:28:33 -040023PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
Brad Bishop0f291cc2019-09-01 15:16:57 -040024PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python"
Brad Bishop19323692019-04-05 15:28:33 -040025PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2"
26PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus, --without-lvm_dbus, multipath-tools, lvm2"
27PACKAGECONFIG[dm] = "--with-dm, --without-dm, multipath-tools, lvm2"
28PACKAGECONFIG[dmraid] = "--with-dmraid, --without-dmraid"
Patrick Williamse760df82023-05-26 11:10:49 -050029PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd,libbytesize"
Brad Bishop19323692019-04-05 15:28:33 -040030PACKAGECONFIG[parted] = "--with-part, --without-part, parted"
31PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux"
32PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
33PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm, ndctl util-linux"
Patrick Williamse760df82023-05-26 11:10:49 -050034PACKAGECONFIG[vdo] = "--with-vdo, --without-vdo,libbytesize"
Brad Bishop19323692019-04-05 15:28:33 -040035PACKAGECONFIG[escrow] = "--with-escrow, --without-escrow, nss volume-key"
36PACKAGECONFIG[btrfs] = "--with-btrfs,--without-btrfs,libbytesize btrfs-tools"
37PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,cryptsetup nss volume-key"
38PACKAGECONFIG[mdraid] = "--with-mdraid,--without-mdraid,libbytesize"
39PACKAGECONFIG[kbd] = "--with-kbd,--without-kbd,libbytesize"
40PACKAGECONFIG[mpath] = "--with-mpath,--without-mpath, multipath-tools, lvm2"
Patrick Williamse760df82023-05-26 11:10:49 -050041PACKAGECONFIG[tools] = "--with-tools,--without-tools,libbytesize libdevmapper"
Brad Bishop19323692019-04-05 15:28:33 -040042
43export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs"