blob: 6d3e81f28fe2ccee21ee59be2b42fa0aa1344ea6 [file] [log] [blame]
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05001SUMMARY = "CMake is an open-source, cross-platform family of tools designed to build, test and package software"
2LICENSE = "BSD-3-Clause & Apache-2.0"
3LIC_FILES_CHKSUM = " \
4 file://LICENSE_BSD_3;md5=9134cb61aebbdd79dd826ccb9ae6afcd \
5 file://LICENSE_Apache_20;md5=19cbd64715b51267a47bf3750cc6a8a5 \
6"
7
8DEPENDS = "ninja-native cmake-native python3-scikit-build-native"
9
10PYPI_PACKAGE = "cmake"
11PYPI_ARCHIVE_NAME_PREFIX = "pypi-"
12
13inherit pypi python_setuptools_build_meta
Andrew Geissler5082cc72023-09-11 08:41:39 -040014SRC_URI[sha256sum] = "70526bbff5eeb7d4d6b921af1b80d2d29828302882f94a2cba93ad7d469b90f6"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050015
16SRC_URI += " \
17 file://CMakeLists.txt \
18 file://run-cmake-from-path.patch \
19"
20
21addtask do_patchbuild after do_patch before do_configure
22
23do_patchbuild () {
24 rm -f ${S}/CMakeLists.txt
25 cp ${WORKDIR}/CMakeLists.txt ${S}/
26}
27
28do_install:append () {
29 rm -rf ${D}${bindir}
30}
31
32RDEPENDS:${PN} = " \
33 cmake \
34 python3-scikit-build \
35"
36
37BBCLASSEXTEND = "native nativesdk"