blob: de2bd3d12ddcbddc542cfb358fe075dd4f19ebaa [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Google API client core library"
2HOMEPAGE = "https://github.com/googleapis/python-api-core"
Andrew Geissler517393d2023-01-13 08:55:19 -06003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6inherit pypi setuptools3
7
Patrick Williams520786c2023-06-25 16:20:36 -05008SRC_URI[sha256sum] = "25d29e05a0058ed5f19c61c0a78b1b53adea4d9364b464d014fbda941f6d1c9a"
Andrew Geissler517393d2023-01-13 08:55:19 -06009
10RDEPENDS:${PN} += "\
11 ${PYTHON_PN}-asyncio \
12 ${PYTHON_PN}-datetime \
13 ${PYTHON_PN}-logging \
14 ${PYTHON_PN}-math \
15"
16
17RDEPENDS:${PN} += "\
18 ${PYTHON_PN}-googleapis-common-protos \
19 ${PYTHON_PN}-google-auth \
20 ${PYTHON_PN}-grpcio \
21 ${PYTHON_PN}-protobuf \
22 ${PYTHON_PN}-pytz \
23 ${PYTHON_PN}-requests \
24 ${PYTHON_PN}-six \
25"