blob: 8ff77ba4fd2cd5b32b0c9af6f3eea56efe688f28 [file] [log] [blame]
Patrick Williams7784c422022-11-17 07:29:11 -06001SUMMARY = "Backported and Experimental Type Hints for Python 3.7+"
2DESCRIPTION = "The typing_extensions module serves two related purposes:\
3\
4* Enable use of new type system features on older Python versions. For \
5 example, typing.TypeGuard is new in Python 3.10, but typing_extensions \
6 allows users on previous Python versions to use it too.\
7* Enable experimentation with new type system PEPs before they are accepted \
8 and added to the typing module."
9HOMEPAGE = "https://github.com/python/typing_extensions"
10BUGTRACKER = "https://github.com/python/typing_extensions/issues"
11SECTIONS = "libs"
12LICENSE = "PSF-2.0"
Andrew Geissler8f840682023-07-21 09:09:43 -050013LIC_FILES_CHKSUM = "file://LICENSE;md5=fcf6b249c2641540219a727f35d8d2c2"
Patrick Williams7784c422022-11-17 07:29:11 -060014
15# The name on PyPi is slightly different.
16PYPI_PACKAGE = "typing_extensions"
17
Andrew Geissler8f840682023-07-21 09:09:43 -050018SRC_URI[sha256sum] = "b75ddc264f0ba5615db7ba217daeb99701ad295353c45f9e95963337ceeeffb2"
Patrick Williams7784c422022-11-17 07:29:11 -060019
20inherit pypi python_flit_core
21
22UPSTREAM_CHECK_REGEX = "/typing-extensions/(?P<pver>(\d+[\.\-_]*)+)/"
23
24BBCLASSEXTEND = "native nativesdk"