blob: 20dccc2356ee25a3cd7ad2c0ea31c60acdffb3b3 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A simple daemon to allow session software to update firmware"
2LICENSE = "LGPL-2.1-or-later"
3LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
4
5DEPENDS = "glib-2.0 libxmlb json-glib sqlite3 libjcat gcab vala-native"
6
Patrick Williamsde0582f2022-04-08 10:23:27 -05007COMPATIBLE_HOST:libc-musl = 'null'
8
Andrew Geissler9aee5002022-03-30 16:27:02 +00009SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BP}.tar.xz \
10 file://run-ptest"
11SRC_URI[sha256sum] = "7ebe1514acb688d2649cecc392db929094da3f03cfc98a9c0faccabb084912fa"
12
13UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
14
15# Machine-specific as we examine MACHINE_FEATURES to decide whether to build the UEFI plugins
16PACKAGE_ARCH = "${MACHINE_ARCH}"
17
18inherit meson vala gobject-introspection systemd bash-completion pkgconfig gi-docgen ptest manpages
19
20GIDOCGEN_MESON_OPTION = 'docs'
21GIDOCGEN_MESON_ENABLE_FLAG = 'docgen'
22GIDOCGEN_MESON_DISABLE_FLAG = 'none'
23
24PACKAGECONFIG ??= "curl gnutls gudev gusb \
25 ${@bb.utils.filter('DISTRO_FEATURES', 'bluetooth polkit', d)} \
26 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd offline', '', d)} \
27 ${@bb.utils.contains('MACHINE_FEATURES', 'efi', 'plugin_uefi_capsule plugin_uefi_pk', '', d)} \
28 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests plugin_dummy', '', d)} \
29 hsi \
30 plugin_acpi_phat \
31 plugin_amt \
32 plugin_bcm57xx \
33 plugin_emmc \
34 plugin_ep963x \
35 plugin_fastboot \
36 plugin_flashrom \
37 plugin_gpio \
38 plugin_intel_spi \
39 plugin_logitech_bulkcontroller \
40 plugin_modem_manager \
41 plugin_msr \
42 plugin_nitrokey \
43 plugin_nvme \
44 plugin_parade_lspcon \
45 plugin_pixart_rf \
46 plugin_platform_integrity \
47 plugin_realtek_mst \
48 plugin_redfish \
49 plugin_synaptics_mst \
50 plugin_synaptics_rmi \
51 plugin_scsi \
52 plugin_thunderbolt \
53 plugin_uf2 \
54 plugin_upower \
55 sqlite"
56
57PACKAGECONFIG[bluetooth] = "-Dbluez=true,-Dbluez=false"
58PACKAGECONFIG[compat-cli] = "-Dcompat_cli=true,-Dcompat_cli=false"
59PACKAGECONFIG[consolekit] = "-Dconsolekit=true,-Dconsolekit=false,consolekit"
60PACKAGECONFIG[curl] = "-Dcurl=true,-Dcurl=false,curl"
61PACKAGECONFIG[firmware-packager] = "-Dfirmware-packager=true,-Dfirmware-packager=false"
62PACKAGECONFIG[fish-completion] = "-Dfish_completion=true,-Dfish_completion=false"
63PACKAGECONFIG[gnutls] = "-Dgnutls=true,-Dgnutls=false,gnutls"
64PACKAGECONFIG[gudev] = "-Dgudev=true,-Dgudev=false,libgudev"
65PACKAGECONFIG[gusb] = "-Dgusb=true,-Dgusb=false,libgusb"
66PACKAGECONFIG[hsi] = "-Dhsi=true,-Dhsi=false"
67PACKAGECONFIG[libarchive] = "-Dlibarchive=true,-Dlibarchive=false,libarchive"
68PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false"
69PACKAGECONFIG[metainfo] = "-Dmetainfo=true,-Dmetainfo=false"
70PACKAGECONFIG[offline] = "-Doffline=true,-Doffline=false"
71PACKAGECONFIG[polkit] = "-Dpolkit=true,-Dpolkit=false,polkit"
72PACKAGECONFIG[sqlite] = "-Dsqlite=true,-Dsqlite=false,sqlite3"
73PACKAGECONFIG[systemd] = "-Dsystemd=true,-Dsystemd=false,systemd"
74PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,gcab-native"
75
76
77# TODO plugins-all meta-option that expands to all plugin_*?
78PACKAGECONFIG[plugin_acpi_phat] = "-Dplugin_acpi_phat=true,-Dplugin_acpi_phat=false"
79PACKAGECONFIG[plugin_amt] = "-Dplugin_amt=true,-Dplugin_amt=false"
80PACKAGECONFIG[plugin_bcm57xx] = "-Dplugin_bcm57xx=true,-Dplugin_bcm57xx=false"
81PACKAGECONFIG[plugin_cfu] = "-Dplugin_cfu=true,-Dplugin_cfu=false"
82PACKAGECONFIG[plugin_dell] = "-Dplugin_dell=true,-Dplugin_dell=false,libsmbios"
83PACKAGECONFIG[plugin_dummy] = "-Dplugin_dummy=true,-Dplugin_dummy=false"
84PACKAGECONFIG[plugin_emmc] = "-Dplugin_emmc=true,-Dplugin_emmc=false"
85PACKAGECONFIG[plugin_ep963x] = "-Dplugin_ep963x=true,-Dplugin_ep963x=false"
86PACKAGECONFIG[plugin_fastboot] = "-Dplugin_fastboot=true,-Dplugin_fastboot=false"
87PACKAGECONFIG[plugin_flashrom] = "-Dplugin_flashrom=true,-Dplugin_flashrom=false,flashrom"
88PACKAGECONFIG[plugin_gpio] = "-Dplugin_gpio=true,-Dplugin_gpio"
89PACKAGECONFIG[plugin_intel_spi] = "-Dplugin_intel_spi=true -Dlzma=true,-Dplugin_intel_spi=false -Dlzma=false,xz"
90PACKAGECONFIG[plugin_logitech_bulkcontroller] = "-Dplugin_logitech_bulkcontroller=true,-Dplugin_logitech_bulkcontroller=false,protobuf-c-native protobuf-c"
91PACKAGECONFIG[plugin_modem_manager] = "-Dplugin_modem_manager=true,-Dplugin_modem_manager=false,libqmi modemmanager"
92PACKAGECONFIG[plugin_msr] = "-Dplugin_msr=true,-Dplugin_msr=false,cpuid"
93PACKAGECONFIG[plugin_nitrokey] = "-Dplugin_nitrokey=true,-Dplugin_nitrokey=false"
94PACKAGECONFIG[plugin_nvme] = "-Dplugin_nvme=true,-Dplugin_nvme=false"
95PACKAGECONFIG[plugin_parade_lspcon] = "-Dplugin_parade_lspcon=true,-Dplugin_parade_lspcon=false"
96PACKAGECONFIG[plugin_pixart_rf] = "-Dplugin_pixart_rf=true,-Dplugin_pixart_rf=false"
97PACKAGECONFIG[plugin_platform_integrity] = "-Dplugin_platform_integrity=true,-Dplugin_platform_integrity=false"
98PACKAGECONFIG[plugin_powerd] = "-Dplugin_powerd=true,-Dplugin_powerd=false"
99PACKAGECONFIG[plugin_realtek_mst] = "-Dplugin_realtek_mst=true,-Dplugin_realtek_mst=false"
100PACKAGECONFIG[plugin_redfish] = "-Dplugin_redfish=true,-Dplugin_redfish=false"
101PACKAGECONFIG[plugin_scsi] = "-Dplugin_scsi=true,-Dplugin_scsi=false"
102PACKAGECONFIG[plugin_synaptics_mst] = "-Dplugin_synaptics_mst=true,-Dplugin_synaptics_mst=false"
103PACKAGECONFIG[plugin_synaptics_rmi] = "-Dplugin_synaptics_rmi=true,-Dplugin_synaptics_rmi=false"
104PACKAGECONFIG[plugin_thunderbolt] = "-Dplugin_thunderbolt=true,-Dplugin_thunderbolt=false"
105PACKAGECONFIG[plugin_tpm] = "-Dplugin_tpm=true,-Dplugin_tpm=false,tpm2-tss"
106# Turn off the capsule splash as it needs G-I at buildtime, which isn't currently supported
107PACKAGECONFIG[plugin_uefi_capsule] = "-Dplugin_uefi_capsule=true -Dplugin_uefi_capsule_splash=false,-Dplugin_uefi_capsule=false,efivar fwupd-efi"
108PACKAGECONFIG[plugin_uefi_pk] = "-Dplugin_uefi_pk=true,-Dplugin_uefi_pk=false"
109PACKAGECONFIG[plugin_uf2] = "-Dplugin_uf2=true,-Dplugin_uf2=false"
110PACKAGECONFIG[plugin_upower] = "-Dplugin_upower=true,-Dplugin_upower=false"
111
112# Always disable these plugins on non-x86 platforms as they don't compile or are useless
113DISABLE_NON_X86 = "plugin_amt plugin_intel_spi plugin_msr plugin_thunderbolt"
114DISABLE_NON_X86:x86 = ""
115DISABLE_NON_X86:x86-64 = ""
116PACKAGECONFIG:remove = "${DISABLE_NON_X86}"
117
118FILES:${PN} += "${libdir}/fwupd-plugins-* \
119 ${systemd_unitdir} \
120 ${datadir}/fish \
121 ${datadir}/metainfo \
122 ${datadir}/icons \
123 ${datadir}/dbus-1 \
124 ${datadir}/polkit-1 \
125 ${nonarch_libdir}/modules-load.d"
126
127FILES:${PN}-ptest += "${libexecdir}/installed-tests/ \
128 ${datadir}/installed-tests/"
129RDEPENDS:${PN}-ptest += "gnome-desktop-testing"